aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/llvm/patches/100-darwin_arch_auto.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
commit13de9a716a6b7e58e3029db284574f0b4fad7eb9 (patch)
tree9805d1be913bda014319f149a2fee2ee1994722f /toolchain/llvm/patches/100-darwin_arch_auto.patch
parent46b99120de90068732d8373489ff6ef2a14d73e2 (diff)
downloadmaster-187ad058-13de9a716a6b7e58e3029db284574f0b4fad7eb9.tar.gz
master-187ad058-13de9a716a6b7e58e3029db284574f0b4fad7eb9.tar.bz2
master-187ad058-13de9a716a6b7e58e3029db284574f0b4fad7eb9.zip
gcc: add llvm-gcc and llvm from trunk (does not successfully compile a target yet, but gets close)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18019 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/llvm/patches/100-darwin_arch_auto.patch')
-rw-r--r--toolchain/llvm/patches/100-darwin_arch_auto.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/toolchain/llvm/patches/100-darwin_arch_auto.patch b/toolchain/llvm/patches/100-darwin_arch_auto.patch
new file mode 100644
index 0000000000..a48e131219
--- /dev/null
+++ b/toolchain/llvm/patches/100-darwin_arch_auto.patch
@@ -0,0 +1,19 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -618,16 +618,6 @@ ifdef UNIVERSAL
+
+ # Building universal cannot compute dependencies automatically.
+ DISABLE_AUTO_DEPENDENCIES=1
+-else
+- ifeq ($(TARGET_OS),Darwin)
+- ifeq ($(ARCH),x86_64)
+- TargetCommonOpts = -m64
+- else
+- ifeq ($(ARCH),x86)
+- TargetCommonOpts = -m32
+- endif
+- endif
+- endif
+ endif
+
+ ifeq ($(HOST_OS),SunOS)