aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/libnotimpl/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-09-24 20:49:31 +0000
committerNicolas Thill <nico@openwrt.org>2006-09-24 20:49:31 +0000
commitecb6c4b599eab655681dbaa3e755709fa1b819b3 (patch)
treeb7ed2e950b1b35de067464525dccaf95f2876cfd /toolchain/libnotimpl/Makefile
parent403a4bfc19147dc962180adb099e5ec9d7ad81c1 (diff)
downloadmaster-187ad058-ecb6c4b599eab655681dbaa3e755709fa1b819b3.tar.gz
master-187ad058-ecb6c4b599eab655681dbaa3e755709fa1b819b3.tar.bz2
master-187ad058-ecb6c4b599eab655681dbaa3e755709fa1b819b3.zip
new (last?) attempt at standardizing Makefiles
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4855 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/libnotimpl/Makefile')
-rw-r--r--toolchain/libnotimpl/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/toolchain/libnotimpl/Makefile b/toolchain/libnotimpl/Makefile
index bc515ca080..d55bf4e3fe 100644
--- a/toolchain/libnotimpl/Makefile
+++ b/toolchain/libnotimpl/Makefile
@@ -6,8 +6,9 @@
#
include $(TOPDIR)/rules.mk
-PKG_NAME := libnotimpl
-PKG_BUILD_DIR := $(TOOL_BUILD_DIR)/libnotimpl
+PKG_NAME:=libnotimpl
+
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/libnotimpl
include $(INCLUDE_DIR)/host-build.mk
@@ -31,9 +32,7 @@ define Build/Install
endef
define Build/Clean
- rm -rf \
- $(STAGING_DIR)/usr/lib/libnotimpl.a \
- $(PKG_BUILD_DIR)
+ rm -f $(STAGING_DIR)/usr/lib/libnotimpl.a
endef
$(eval $(call HostBuild))