aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/libnotimpl/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-10-31 11:29:54 +0000
committerNicolas Thill <nico@openwrt.org>2006-10-31 11:29:54 +0000
commit4a45e20e4b73be93e2bfcb40949ba5376bbbcc9e (patch)
tree22c4b27835016b3aa24c25631403013f5b351417 /toolchain/libnotimpl/Makefile
parenta12078d574eabfe76ab71b1062ca982314a5f6d7 (diff)
downloadmaster-187ad058-4a45e20e4b73be93e2bfcb40949ba5376bbbcc9e.tar.gz
master-187ad058-4a45e20e4b73be93e2bfcb40949ba5376bbbcc9e.tar.bz2
master-187ad058-4a45e20e4b73be93e2bfcb40949ba5376bbbcc9e.zip
move libnotimpl to /packages/libs, fix another typo in ./src/math.c
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5355 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/libnotimpl/Makefile')
-rw-r--r--toolchain/libnotimpl/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/toolchain/libnotimpl/Makefile b/toolchain/libnotimpl/Makefile
deleted file mode 100644
index 85156723be..0000000000
--- a/toolchain/libnotimpl/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libnotimpl
-
-PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/libnotimpl
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define cc
- $(TARGET_CC) $(TARGET_CFLAGS) -c src/$(1).c -o $(PKG_BUILD_DIR)/$(1).o
-endef
-
-define Build/Prepare
- rm -rf $(PKG_BUILD_DIR)
- mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Compile
- $(call cc,math)
- $(TARGET_CROSS)ar rc $(PKG_BUILD_DIR)/libnotimpl.a $(PKG_BUILD_DIR)/*.o
-endef
-
-define Build/Install
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libnotimpl.a $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/Clean
- rm -f $(STAGING_DIR)/usr/lib/libnotimpl.a
-endef
-
-$(eval $(call HostBuild))
-