aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
commitf0f9ec9c5626a4124234638a0ed2f4c99c435ff8 (patch)
treeeaa59400aae15a69c47faa369e3bf53690f18592 /toolchain/glibc
parentba5b41f0dcd3b89ab6ff031147d99ec6d4a132ef (diff)
downloadmaster-187ad058-f0f9ec9c5626a4124234638a0ed2f4c99c435ff8.tar.gz
master-187ad058-f0f9ec9c5626a4124234638a0ed2f4c99c435ff8.tar.bz2
master-187ad058-f0f9ec9c5626a4124234638a0ed2f4c99c435ff8.zip
add a modified version of the mips64 patch from #4603
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15249 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/glibc')
-rw-r--r--toolchain/glibc/Config.version6
-rw-r--r--toolchain/glibc/Makefile1
2 files changed, 4 insertions, 3 deletions
diff --git a/toolchain/glibc/Config.version b/toolchain/glibc/Config.version
index d68eeea8a9..1debf0c040 100644
--- a/toolchain/glibc/Config.version
+++ b/toolchain/glibc/Config.version
@@ -9,7 +9,7 @@ config GLIBC_VERSION
config GLIBC_PORTS
bool
depends on USE_GLIBC
- default y if GLIBC_VERSION_2_3_6 && (arm || armeb || mips || mipsel)
- default y if GLIBC_VERSION_2_6_1 && (arm || armeb || mips || mipsel || powerpc)
- default y if GLIBC_VERSION_2_7 && (arm || armeb || mips || mipsel || powerpc)
+ default y if GLIBC_VERSION_2_3_6 && (arm || armeb || mips || mipsel || mips64 || mips64el)
+ default y if GLIBC_VERSION_2_6_1 && (arm || armeb || mips || mipsel || mips64 || mips64el || powerpc)
+ default y if GLIBC_VERSION_2_7 && (arm || armeb || mips || mipsel || mips64 || mips64el || powerpc)
default n
diff --git a/toolchain/glibc/Makefile b/toolchain/glibc/Makefile
index d014cacded..054d891303 100644
--- a/toolchain/glibc/Makefile
+++ b/toolchain/glibc/Makefile
@@ -57,6 +57,7 @@ GLIBC_CONFIGURE:= \
--build=$(GNU_HOST_NAME) \
--host=$(REAL_GNU_TARGET_NAME) \
--with-headers="$(TOOLCHAIN_DIR)/usr/include" \
+ $(if $(CONFIG_mips64)$(CONFIG_mips64el), --enable-kernel="2.6.0") \
--disable-debug \
--disable-profile \
--enable-add-ons="$(GLIBC_ADD_ONS)" \