aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/common.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-02-25 13:43:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-02-25 13:43:46 +0000
commitbb1eb229d7489c553b3e247fec38b1eb30d80d3d (patch)
tree31107f9de55f92b7e26798c12bfc53cd67bc4390 /toolchain/glibc/common.mk
parentb6b7bcd88576ec0c11ffc193a21501245ecd7a31 (diff)
downloadmaster-187ad058-bb1eb229d7489c553b3e247fec38b1eb30d80d3d.tar.gz
master-187ad058-bb1eb229d7489c553b3e247fec38b1eb30d80d3d.tar.bz2
master-187ad058-bb1eb229d7489c553b3e247fec38b1eb30d80d3d.zip
toolchain/glibc: remove obsolete versions
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48780 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/glibc/common.mk')
-rw-r--r--toolchain/glibc/common.mk14
1 files changed, 0 insertions, 14 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 042e63d510..4de9905f34 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -30,12 +30,6 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REVISION)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
GLIBC_PATH:=
-ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)
- GLIBC_PATH:=libc/
- PKG_SOURCE_PROTO:=svn
- PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
- PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_19
-endif
PATCH_DIR:=$(PATH_PREFIX)/patches/$(PKG_VERSION)
@@ -85,11 +79,7 @@ export HOST_CFLAGS := $(HOST_CFLAGS) -idirafter $(CURDIR)/$(PATH_PREFIX)/include
define Host/SetToolchainInfo
$(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
-ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)
- $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.eglibc.org/,' $(TOOLCHAIN_DIR)/info.mk
-else
$(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.gnu.org/software/libc/,' $(TOOLCHAIN_DIR)/info.mk
-endif
$(SED) 's,^\(LIBC_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
$(SED) 's,^\(LIBC_SO_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
endef
@@ -101,7 +91,6 @@ define Host/Configure
touch $(HOST_BUILD_DIR)/.autoconf; \
}
mkdir -p $(CUR_BUILD_DIR)
- grep 'CONFIG_EGLIBC_OPTION_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_EGLIBC_\\(.*\\),\\1\\2,g" > $(CUR_BUILD_DIR)/option-groups.config
( cd $(CUR_BUILD_DIR); rm -f config.cache; \
$(GLIBC_CONFIGURE) \
);
@@ -110,9 +99,6 @@ endef
define Host/Prepare
$(call Host/Prepare/Default)
ln -snf $(PKG_SOURCE_SUBDIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
-ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)
- $(SED) 's,y,n,' $(HOST_BUILD_DIR)/libc/option-groups.defaults
-endif
endef
define Host/Clean