aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-07 12:48:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-07 12:48:23 +0000
commit2aea2ee11654986b7b34d35db5916a34ab15c578 (patch)
treedca20158175f5d3a6fefa8773a747e20063e8712 /toolchain/gdb
parent8f9b08fbd82f5108202115a3458259b185814ac4 (diff)
downloadmaster-187ad058-2aea2ee11654986b7b34d35db5916a34ab15c578.tar.gz
master-187ad058-2aea2ee11654986b7b34d35db5916a34ab15c578.tar.bz2
master-187ad058-2aea2ee11654986b7b34d35db5916a34ab15c578.zip
fix gdb installation (patch from #809)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4945 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 63661ca2dc..34dca715a7 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -40,9 +40,16 @@ define Build/Compile
endef
define Build/Install
- install -c $(PKG_BUILD_DIR)/gdb/gdb $(TARGET_CROSS)gdb
- cd $(STAGING_DIR)/bin && \
- ln -fs $(TARGET_CROSS)gdb $(GNU_TARGET_NAME)-gdb
+ (cd $(STAGING_DIR)/bin; \
+ install -c $(PKG_BUILD_DIR)/gdb/gdb $(TARGET_CROSS)gdb; \
+ ln -fs $(TARGET_CROSS)gdb $(GNU_TARGET_NAME)-gdb; \
+ );
+endef
+
+define Build/Clean
+ rm -rf $(PKG_BUILD_DIR)
+ rm -f $(STAGING_DIR)/bin/$(TARGET_CROSS)gdb
+ rm -f $(STAGING_DIR)/bin/$(GNU_TARGET_NAME)-gdb
endef
$(eval $(call HostBuild))