aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-17 12:38:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-17 12:38:32 +0000
commit3dcc07fa23bf582dce314d9dc1987a4a2494de4d (patch)
tree5398ff44e78717130d03322591248dafdba5f584 /toolchain/gdb/Makefile
parent737a3bcc76e5185b49e9661d9a56dbcd6b5802a3 (diff)
downloadmaster-187ad058-3dcc07fa23bf582dce314d9dc1987a4a2494de4d.tar.gz
master-187ad058-3dcc07fa23bf582dce314d9dc1987a4a2494de4d.tar.bz2
master-187ad058-3dcc07fa23bf582dce314d9dc1987a4a2494de4d.zip
gdb: use separate patches for upstream and ARC gdb
With bump of upstream GDB from 7.9 to 7.10 at least 100-no_extern_inline.patch became incompatible with ARC gdb (which is still based on upstream 7.9 branch). So until ARC support is not completely upstreamed (which we expect to happen in coming months) we'll need to have separate patches for ARC gdb. This time clean build-tested for Netgear WNDRMAC & AXS101. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: John Crispin <blogic@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47491 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gdb/Makefile')
-rw-r--r--toolchain/gdb/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 38ffb0b77f..f74b64ed94 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -24,6 +24,8 @@ PKG_MD5SUM:=2a35bac41fa8e10bf04f3a0dd7f7f363
GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
endif
+PATCH_DIR:=./patches/$(PKG_VERSION)
+
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
HOST_BUILD_PARALLEL:=1