aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-12 17:01:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-12 17:01:57 +0000
commitf8772209730f182959164ee29f5f7c488b573180 (patch)
tree70033eef376f70ae32c7c71fdf212602bff06606 /toolchain/gcc
parent171f3274a4a11cfdc15ab9f181fcdb6d15d8cbbd (diff)
downloadmaster-187ad058-f8772209730f182959164ee29f5f7c488b573180.tar.gz
master-187ad058-f8772209730f182959164ee29f5f7c488b573180.tar.bz2
master-187ad058-f8772209730f182959164ee29f5f7c488b573180.zip
gcc: don't clobber stamp-bits with a symlink to itself
Several versions of gcc have an issue in libstdc++v3 where the build may clobber stamp-bits with a link to itself. This doesn't manifest itself on all systems. On several Ubuntu systems, this doesn't appear to be a problem, but it is an issue on Fedora 16 systems. To fix the issue, we'll simply filter out stamp-bits from the symlinks to be generated. Note: gcc 4.4.7 is unaffected by this issue, so no fix is necessary there. Signed-off-by: John Szakmeister <john@szakmeister.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43669 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/patches/4.6-linaro/940-no-clobber-stamp-bits.patch11
-rw-r--r--toolchain/gcc/patches/4.8-linaro/940-no-clobber-stamp-bits.patch11
-rw-r--r--toolchain/gcc/patches/4.9-linaro/940-no-clobber-stamp-bits.patch13
3 files changed, 35 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/4.6-linaro/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/4.6-linaro/940-no-clobber-stamp-bits.patch
new file mode 100644
index 0000000000..9106a4adc7
--- /dev/null
+++ b/toolchain/gcc/patches/4.6-linaro/940-no-clobber-stamp-bits.patch
@@ -0,0 +1,11 @@
+--- a/libstdc++-v3/include/Makefile.in
++++ b/libstdc++-v3/include/Makefile.in
+@@ -1326,7 +1326,7 @@
+ @$(STAMP) stamp-bits
+
+ stamp-bits-sup: stamp-bits ${bits_sup_headers}
+- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
++ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
+ @$(STAMP) stamp-bits-sup
+
+ stamp-c_base: ${c_base_headers}
diff --git a/toolchain/gcc/patches/4.8-linaro/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/4.8-linaro/940-no-clobber-stamp-bits.patch
new file mode 100644
index 0000000000..dbecef2d57
--- /dev/null
+++ b/toolchain/gcc/patches/4.8-linaro/940-no-clobber-stamp-bits.patch
@@ -0,0 +1,11 @@
+--- a/libstdc++-v3/include/Makefile.in
++++ b/libstdc++-v3/include/Makefile.in
+@@ -1342,7 +1342,7 @@
+ @$(STAMP) stamp-bits
+
+ stamp-bits-sup: stamp-bits ${bits_sup_headers}
+- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
++ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
+ @$(STAMP) stamp-bits-sup
+
+ stamp-c_base: ${c_base_headers}
diff --git a/toolchain/gcc/patches/4.9-linaro/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/4.9-linaro/940-no-clobber-stamp-bits.patch
new file mode 100644
index 0000000000..f874255819
--- /dev/null
+++ b/toolchain/gcc/patches/4.9-linaro/940-no-clobber-stamp-bits.patch
@@ -0,0 +1,13 @@
+Index: gcc-linaro-4.9-2014.10/libstdc++-v3/include/Makefile.in
+===================================================================
+--- gcc-linaro-4.9-2014.10.orig/libstdc++-v3/include/Makefile.in 2013-11-16 12:44:48.000000000 -0500
++++ gcc-linaro-4.9-2014.10/libstdc++-v3/include/Makefile.in 2014-12-02 06:23:02.236660279 -0500
+@@ -1366,7 +1366,7 @@
+ @$(STAMP) stamp-bits
+
+ stamp-bits-sup: stamp-bits ${bits_sup_headers}
+- @-cd ${bits_builddir} && $(LN_S) $? . 2>/dev/null
++ @-cd ${bits_builddir} && $(LN_S) $(filter-out stamp-bits,$?) . 2>/dev/null
+ @$(STAMP) stamp-bits-sup
+
+ stamp-c_base: ${c_base_headers}