aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-18 08:22:17 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-18 08:22:17 +0000
commitd698d2584beff7860f1784873d1e97038620528a (patch)
tree03116639f999ccebf6ea38dc1e9b0ce74b53552c /toolchain/gcc
parent1baafddcc3230fe12b25f309b79e7ab08ce0d5c6 (diff)
downloadmaster-187ad058-d698d2584beff7860f1784873d1e97038620528a.tar.gz
master-187ad058-d698d2584beff7860f1784873d1e97038620528a.tar.bz2
master-187ad058-d698d2584beff7860f1784873d1e97038620528a.zip
toolchain: add support of ARCv2 architecture
This change adds support of ARC ISAv2 processors in OpenWRT toolchain. In general gcc for ARC may compile code for both ISA versions simultaneously but libgcc will be built only for default architecture that's why it's necessary to specify --with-cpu on gcc configuration. As for uClibc we need to use different configurations for different ARC ISAs. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48739 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 2912f8f612..6ac5a46f2d 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -111,6 +111,7 @@ GCC_CONFIGURE:= \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \
--with-abi=$(call qstrip,$(CONFIG_MIPS64_ABI))) \
+ $(if $(CONFIG_arc),--with-cpu=$(CONFIG_CPU_TYPE)) \
--with-gmp=$(TOPDIR)/staging_dir/host \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--with-mpc=$(TOPDIR)/staging_dir/host \