aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-06-20 17:37:20 +0000
committerSteven Barth <steven@midlink.org>2015-06-20 17:37:20 +0000
commitae1b787c52173ea2fc7377f63e7406a22afdd87c (patch)
tree780f1e36a62eb0a274d118b567b0a658ac1a51a5 /toolchain/gcc
parent44ef4732478819835d1ef8f7e05fe01d3b765160 (diff)
downloadmaster-187ad058-ae1b787c52173ea2fc7377f63e7406a22afdd87c.tar.gz
master-187ad058-ae1b787c52173ea2fc7377f63e7406a22afdd87c.tar.bz2
master-187ad058-ae1b787c52173ea2fc7377f63e7406a22afdd87c.zip
gcc: musl comes with its own SSP, so use it instead of libssp
Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46071 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/final/Makefile4
-rw-r--r--toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch11
2 files changed, 15 insertions, 0 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 3fb5ccf83f..1212d145ab 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -16,6 +16,10 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
--with-libelf=$(TOPDIR)/staging_dir/host
endif
+ifdef CONFIG_USE_MUSL
+ GCC_MAKE += gcc_cv_libc_provides_ssp=yes
+endif
+
ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
GCC_CONFIGURE += \
--enable-sjlj-exceptions
diff --git a/toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch b/toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch
new file mode 100644
index 0000000000..1208e73029
--- /dev/null
+++ b/toolchain/gcc/patches/4.8-linaro/030-always-link-ssp-noshared.patch
@@ -0,0 +1,11 @@
+--- gcc-4.7.4.org/gcc/gcc.c
++++ gcc-4.7.4/gcc/gcc.c
+@@ -603,7 +603,7 @@
+
+ #ifndef LINK_SSP_SPEC
+ #ifdef TARGET_LIBC_PROVIDES_SSP
+-#define LINK_SSP_SPEC "%{fstack-protector:}"
++#define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all:-lssp_nonshared}"
+ #else
+ #define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all:-lssp_nonshared -lssp}"
+ #endif