aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-12 03:42:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-12 03:42:05 +0000
commit87f59ecd7c9bddefaf9710b21f61b1d5a310ebfc (patch)
treec91525abeee7c432163e66a0753f54b85bd1b813 /toolchain/gcc
parent52f3a41d91e4e5479ff1a3611227bc6ef4c8dd94 (diff)
downloadmaster-187ad058-87f59ecd7c9bddefaf9710b21f61b1d5a310ebfc.tar.gz
master-187ad058-87f59ecd7c9bddefaf9710b21f61b1d5a310ebfc.tar.bz2
master-187ad058-87f59ecd7c9bddefaf9710b21f61b1d5a310ebfc.zip
fix gcc compile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5511 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index af06e8a4c1..a738345d2e 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -64,10 +64,10 @@ define Stage1/Configure
);
endef
define Stage1/Compile
- $(MAKE) -C $(BUILD_DIR1) all-gcc SHELL="$(BASH)"
+ export SHELL="$(BASH)"; $(MAKE) -C $(BUILD_DIR1) all-gcc
endef
define Stage1/Install
- $(MAKE) -C $(BUILD_DIR1) install-gcc SHELL="$(BASH)"
+ export SHELL="$(BASH)"; $(MAKE) -C $(BUILD_DIR1) install-gcc
endef
define Stage2/Configure
@@ -93,10 +93,10 @@ define Stage2/Configure
);
endef
define Stage2/Compile
- $(MAKE) -C $(BUILD_DIR2) all SHELL="$(BASH)"
+ export SHELL="$(BASH)"; $(MAKE) -C $(BUILD_DIR2) all
endef
define Stage2/Install
- $(MAKE) -C $(BUILD_DIR2) install SHELL="$(BASH)"
+ export SHELL="$(BASH)"; $(MAKE) -C $(BUILD_DIR2) install
echo $(PKG_VERSION) > $(STAGING_DIR)/gcc_version
# Set up the symlinks to enable lying about target name.
set -e; \