aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-27 01:11:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-27 01:11:35 +0000
commit4ffee7b6f04ac153dcd65a104fd697c7a4b3e01d (patch)
treede4722329d31c52fb94e952d4f290ac65ceed138 /toolchain/gcc
parent763125a8733b8aa4d4661373c02caee56449445a (diff)
downloadmaster-187ad058-4ffee7b6f04ac153dcd65a104fd697c7a4b3e01d.tar.gz
master-187ad058-4ffee7b6f04ac153dcd65a104fd697c7a4b3e01d.tar.bz2
master-187ad058-4ffee7b6f04ac153dcd65a104fd697c7a4b3e01d.zip
gcc: compile libgcc and libstdc++ with -O2 instead of -Os on power pc to avoid generating references to gpr save/restore functions which cannot yet be resolved at this point
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18177 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 3b31127b4a..77243c5fa4 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -151,6 +151,10 @@ GCC_CONFIGURE_STAGE2:= \
--disable-tls \
--with-slibdir=$(TOOLCHAIN_DIR)/lib \
+ifdef CONFIG_powerpc
+ TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
+endif
+
GCC_MAKE:= \
export SHELL="$(BASH)"; \
$(MAKE) \