aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-05-23 10:21:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-05-23 10:21:59 +0000
commita4e85cf9aaabdce8e8aba34e316415cd0db8ce96 (patch)
treeff0fad923b18a169156e32d45a4eedfd0feb0cf3 /toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch
parentcee5ff18dea4194fb3834ccc40d183713350c53e (diff)
downloadmaster-187ad058-a4e85cf9aaabdce8e8aba34e316415cd0db8ce96.tar.gz
master-187ad058-a4e85cf9aaabdce8e8aba34e316415cd0db8ce96.tar.bz2
master-187ad058-a4e85cf9aaabdce8e8aba34e316415cd0db8ce96.zip
gcc: port missing patches from 4.6 to 4.8
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36693 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch')
-rw-r--r--toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch b/toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch
new file mode 100644
index 0000000000..4a77b86c17
--- /dev/null
+++ b/toolchain/gcc/patches/4.8-linaro/850-use_shared_libgcc.patch
@@ -0,0 +1,58 @@
+--- a/gcc/config/arm/linux-eabi.h
++++ b/gcc/config/arm/linux-eabi.h
+@@ -114,10 +114,6 @@
+ #define ENDFILE_SPEC \
+ LINUX_OR_ANDROID_LD (GNU_USER_TARGET_ENDFILE_SPEC, ANDROID_ENDFILE_SPEC)
+
+-/* Use the default LIBGCC_SPEC, not the version in linux-elf.h, as we
+- do not use -lfloat. */
+-#undef LIBGCC_SPEC
+-
+ /* Clear the instruction cache from `beg' to `end'. This is
+ implemented in lib1funcs.S, so ensure an error if this definition
+ is used. */
+--- a/gcc/config/linux.h
++++ b/gcc/config/linux.h
+@@ -51,6 +51,10 @@ see the files COPYING3 and COPYING.RUNTI
+ builtin_assert ("system=posix"); \
+ } while (0)
+
++#ifndef LIBGCC_SPEC
++#define LIBGCC_SPEC "%{static|static-libgcc:-lgcc}%{!static:%{!static-libgcc:-lgcc_s}}"
++#endif
++
+ /* Determine which dynamic linker to use depending on whether GLIBC or
+ uClibc or Bionic is the default C library and whether
+ -muclibc or -mglibc or -mbionic has been passed to change the default. */
+--- a/libgcc/mkmap-symver.awk
++++ b/libgcc/mkmap-symver.awk
+@@ -132,5 +132,5 @@ function output(lib) {
+ else if (inherit[lib])
+ printf("} %s;\n", inherit[lib]);
+ else
+- printf ("\n local:\n\t*;\n};\n");
++ printf ("\n\t*;\n};\n");
+ }
+--- a/libgcc/Makefile.in
++++ b/libgcc/Makefile.in
+@@ -368,7 +368,7 @@ endif
+ # For -fvisibility=hidden. We need both a -fvisibility=hidden on
+ # the command line, and a #define to prevent libgcc2.h etc from
+ # overriding that with #pragmas.
+-vis_hide = @vis_hide@
++vis_hide =
+
+ ifneq (,$(vis_hide))
+
+--- a/gcc/config/rs6000/linux.h
++++ b/gcc/config/rs6000/linux.h
+@@ -61,6 +61,9 @@
+ #undef CPLUSPLUS_CPP_SPEC
+ #define CPLUSPLUS_CPP_SPEC "-D_GNU_SOURCE %(cpp)"
+
++#undef LIBGCC_SPEC
++#define LIBGCC_SPEC "%{!static:%{!static-libgcc:-lgcc_s}} -lgcc"
++
+ #undef LINK_SHLIB_SPEC
+ #define LINK_SHLIB_SPEC "%{shared:-shared} %{!shared: %{static:-static}}"
+