aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/initial
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
commitf1f392ab5f9174a11c1cce71567316100187be39 (patch)
tree3c5ffce597429d02d40c40f77b277034d4002ece /toolchain/gcc/initial
parente0456989091285381c7c2acc3a0fdd6c96f1175e (diff)
downloadmaster-187ad058-f1f392ab5f9174a11c1cce71567316100187be39.tar.gz
master-187ad058-f1f392ab5f9174a11c1cce71567316100187be39.tar.bz2
master-187ad058-f1f392ab5f9174a11c1cce71567316100187be39.zip
toolchain: fix the sysroot mess by getting rid of $(TOOLCHAIN_DIR)/usr and moving it back to $(TOOLCHAIN_DIR), this change makes the toolchain relocatable again, which should fix the SDK
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22723 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/initial')
-rw-r--r--toolchain/gcc/initial/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gcc/initial/Makefile b/toolchain/gcc/initial/Makefile
index 8cc6b3be14..f3f78b0b2f 100644
--- a/toolchain/gcc/initial/Makefile
+++ b/toolchain/gcc/initial/Makefile
@@ -4,7 +4,7 @@ include ../common.mk
GCC_CONFIGURE += \
--with-newlib \
- --with-sysroot=$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev \
+ --with-sysroot=$(TOOLCHAIN_DIR) \
--enable-languages=c \
--disable-shared \
--disable-threads \
@@ -23,7 +23,7 @@ define Host/Install
$(if $(GCC_BUILD_TARGET_LIBGCC),install-target-libgcc)
# XXX: glibc insists on linking against libgcc_eh
- ( cd $(TOOLCHAIN_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
+ ( cd $(TOOLCHAIN_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
[ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \
cp libgcc.a libgcc_initial.a; \
)