aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-20 20:49:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-20 20:49:34 +0000
commit501b42a623765badb778ee5f3954c115bb45b179 (patch)
tree836d1b5d183b4773cfcce4468df2fce7ee3cf486 /toolchain/gcc/common.mk
parent32b6ebf57c2704ebbb8c9c1077a19ffb9205fe83 (diff)
downloadmaster-187ad058-501b42a623765badb778ee5f3954c115bb45b179.tar.gz
master-187ad058-501b42a623765badb778ee5f3954c115bb45b179.tar.bz2
master-187ad058-501b42a623765badb778ee5f3954c115bb45b179.zip
gcc: enable non-PIC for mips targets in gcc 4.4+ to reduce code size
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23103 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 645cf60d1d..e2277207b8 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -122,6 +122,12 @@ GCC_CONFIGURE:= \
$(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
$(if $(CONFIG_GCC_VERSION_4_3_3_CS)$(CONFIG_GCC_VERSION_4_4_1_CS)$(CONFIG_GCC_VERSION_4_4_3_CS),--enable-poison-system-directories)
+ifneq ($(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
+ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+ GCC_CONFIGURE += --with-mips-plt
+ endif
+endif
+
ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5),)
GCC_BUILD_TARGET_LIBGCC:=y
GCC_CONFIGURE+= \