aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-07-02 07:50:26 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-07-02 07:50:26 +0000
commit462da430749c5aea0cb66a7209d0f789c2515463 (patch)
tree8b614b366c9a58b5ef8ec985bc5e9a7391552b04 /toolchain/gcc/common.mk
parent6c702de066b04dd9db9d616f399ff6130be406fe (diff)
downloadmaster-187ad058-462da430749c5aea0cb66a7209d0f789c2515463.tar.gz
master-187ad058-462da430749c5aea0cb66a7209d0f789c2515463.tar.bz2
master-187ad058-462da430749c5aea0cb66a7209d0f789c2515463.zip
[toolchain/gcc]: simplify configuration
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27353 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk15
1 files changed, 4 insertions, 11 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 2762f6ad09..d2177c5468 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -104,27 +104,20 @@ GCC_CONFIGURE:= \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
$(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
-ifneq ($(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
- ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
- GCC_CONFIGURE += --with-mips-plt
- endif
-endif
-
ifeq ($(CONFIG_GCC_LLVM),)
GCC_BUILD_TARGET_LIBGCC:=y
GCC_CONFIGURE+= \
--with-gmp=$(TOPDIR)/staging_dir/host \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--disable-decimal-float
+ ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
+ GCC_CONFIGURE += --with-mips-plt
+ endif
endif
ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
- GCC_BUILD_TARGET_LIBGCC:=y
GCC_CONFIGURE+= \
- --with-gmp=$(TOPDIR)/staging_dir/host \
- --with-mpc=$(TOPDIR)/staging_dir/host \
- --with-mpfr=$(TOPDIR)/staging_dir/host \
- --disable-decimal-float
+ --with-mpc=$(TOPDIR)/staging_dir/host
endif
ifneq ($(CONFIG_SSP_SUPPORT),)