aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-04 18:41:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-04 18:41:08 +0000
commit1b6675367e2e57bb7fe3ae7edcd7b802004b839c (patch)
tree490ca362da7532b93334f1b28844ba999da2f2af /toolchain/gcc/Makefile
parentfe799c19a6b8d1a5a4f4e1fcee3eba9bf58cbca4 (diff)
downloadmaster-187ad058-1b6675367e2e57bb7fe3ae7edcd7b802004b839c.tar.gz
master-187ad058-1b6675367e2e57bb7fe3ae7edcd7b802004b839c.tar.bz2
master-187ad058-1b6675367e2e57bb7fe3ae7edcd7b802004b839c.zip
fix the uclibc rebuild issue which leads to unresolved symbols in libnl (and possibly other libraries)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15599 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/gcc/Makefile')
-rw-r--r--toolchain/gcc/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 346971c658..e9598d8177 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -176,6 +176,7 @@ define Stage1/Install
# XXX: glibc insists on linking against libgcc_eh
( cd $(TOOLCHAIN_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
[ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \
+ cp libgcc.a libgcc_initial.a; \
)
endef