aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-27 13:00:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-27 13:00:09 +0000
commitb62cdc2ed6b95633d59e0a6df8edb1ab0455beba (patch)
treee87796b39ff156cb0d8e94d3568dfbd43b9effa6 /toolchain/binutils
parent6c2782f025313820f175597673284bac91643ecf (diff)
downloadmaster-187ad058-b62cdc2ed6b95633d59e0a6df8edb1ab0455beba.tar.gz
master-187ad058-b62cdc2ed6b95633d59e0a6df8edb1ab0455beba.tar.bz2
master-187ad058-b62cdc2ed6b95633d59e0a6df8edb1ab0455beba.zip
binutils: run install twice instead of overwriting the final toolchain with the initial one
fixes compiler error after a binutils rebuild/reinstall without rebuilding the rest of the toolchain Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43785 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 8e661b98eb..8441f740ac 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -84,9 +84,11 @@ define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) \
prefix=$(TOOLCHAIN_DIR)/initial \
install
+ $(MAKE) -C $(HOST_BUILD_DIR) \
+ prefix=$(TOOLCHAIN_DIR) \
+ install
$(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
$(RM) $(TOOLCHAIN_DIR)/initial/lib/libiberty.a
- $(CP) $(TOOLCHAIN_DIR)/initial/. $(TOOLCHAIN_DIR)/
$(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
endef