aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-30 18:12:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-30 18:12:15 +0000
commit488f47237e196cfe24bbeee4c237db19d304e7f8 (patch)
treee9741f4053e435dcac945ef01c5cf1593029a8f6 /toolchain/binutils
parent477607f2e14d11f7afd1616ef508e68a3af35ef3 (diff)
downloadmaster-187ad058-488f47237e196cfe24bbeee4c237db19d304e7f8.tar.gz
master-187ad058-488f47237e196cfe24bbeee4c237db19d304e7f8.tar.bz2
master-187ad058-488f47237e196cfe24bbeee4c237db19d304e7f8.zip
toolchain: keep the initial gcc around for later uclibc rebuilds
testing uclibc changes is tricky because the final gcc tends to miscompile uclibc code or barf up internal compiler errors. install binutils into $(TOOLCHAIN_DIR)/initial (without changing the configure prefix) and copy it from there to $(TOOLCHAIN_DIR)/ so that the initial gcc can be put into $(PATH) for the uclibc build, even if the final gcc is already installed. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32553 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 0022202d4b..9d12721dec 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -79,7 +79,11 @@ define Host/Compile
endef
define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) install
+ mkdir -p $(TOOLCHAIN_DIR)/initial
+ $(MAKE) -C $(HOST_BUILD_DIR) \
+ prefix=$(TOOLCHAIN_DIR)/initial \
+ install
+ $(CP) $(TOOLCHAIN_DIR)/initial/. $(TOOLCHAIN_DIR)/
$(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
endef