aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-18 19:25:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-18 19:25:24 +0000
commit31cedb36a206c2107c3e9f577c360600856d681c (patch)
treec7b7d17a59edc2f0983de5533e9f6ffc3aab9340 /toolchain/binutils
parentdfb392d4db3605f1683c3c27a601a203bd7aed41 (diff)
downloadmaster-187ad058-31cedb36a206c2107c3e9f577c360600856d681c.tar.gz
master-187ad058-31cedb36a206c2107c3e9f577c360600856d681c.tar.bz2
master-187ad058-31cedb36a206c2107c3e9f577c360600856d681c.zip
toolchain: fix binutils broken symlink
The Makefile for binutils creates a broken symlink to "binutils-linaro" in "trunk/build_dir/toolchain-<target>_gcc-4.9-linaro_uClibc-0.9.33.2". Modify the Makefile to point the symlink to the correct directory. Signed-off-by: Nathan Hintz <nlhintz@hotmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42954 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 567f88a854..b88fbd8b2c 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -63,7 +63,7 @@ endif
define Host/Prepare
$(call Host/Prepare/Default)
- ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+ ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
endef