aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-12-28 18:26:50 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-12-28 18:26:50 +0000
commit43fd42318b38d2c8d3a6f5f4b27f12ed9d13a159 (patch)
tree6483a770ade999fd283c206363c8e53ada778971 /toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch
parentffc2b70896118b86f162338fce173641b58d4496 (diff)
downloadmaster-187ad058-43fd42318b38d2c8d3a6f5f4b27f12ed9d13a159.tar.gz
master-187ad058-43fd42318b38d2c8d3a6f5f4b27f12ed9d13a159.tar.bz2
master-187ad058-43fd42318b38d2c8d3a6f5f4b27f12ed9d13a159.zip
update AVR32 binutils patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10006 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch')
-rw-r--r--toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch b/toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch
new file mode 100644
index 0000000000..bd519a1e69
--- /dev/null
+++ b/toolchain/binutils/patches/2.17/501-avr32-fix-pool-alignment.patch
@@ -0,0 +1,26 @@
+Index: a/gas/config/tc-avr32.c
+===================================================================
+--- a/gas/config/tc-avr32.c (revision 31496)
++++ b/gas/config/tc-avr32.c (revision 32014)
+@@ -3092,6 +3092,8 @@
+
+ /* Make sure the constant pool is properly aligned */
+ frag_align_code(2, 0);
++ if (bfd_get_section_alignment(stdoutput, pool->section) < 2)
++ bfd_set_section_alignment(stdoutput, pool->section, 2);
+
+ /* Assume none of the entries are discarded, and that we need the
+ maximum amount of alignment. But we're not going to allocate
+Index: a/bfd/configure.in
+===================================================================
+--- a/bfd/configure.in (revision 31496)
++++ b/bfd/configure.in (revision 32014)
+@@ -8,7 +8,7 @@
+ AC_CANONICAL_TARGET
+ AC_ISC_POSIX
+
+-AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.0)
++AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.1)
+
+ dnl These must be called before AM_PROG_LIBTOOL, because it may want
+ dnl to call AC_CHECK_PROG.