aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
commitf1f392ab5f9174a11c1cce71567316100187be39 (patch)
tree3c5ffce597429d02d40c40f77b277034d4002ece /toolchain/binutils/Makefile
parente0456989091285381c7c2acc3a0fdd6c96f1175e (diff)
downloadmaster-187ad058-f1f392ab5f9174a11c1cce71567316100187be39.tar.gz
master-187ad058-f1f392ab5f9174a11c1cce71567316100187be39.tar.bz2
master-187ad058-f1f392ab5f9174a11c1cce71567316100187be39.zip
toolchain: fix the sysroot mess by getting rid of $(TOOLCHAIN_DIR)/usr and moving it back to $(TOOLCHAIN_DIR), this change makes the toolchain relocatable again, which should fix the SDK
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22723 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/binutils/Makefile')
-rw-r--r--toolchain/binutils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 423cec83c3..5682698bcf 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -41,7 +41,7 @@ include $(INCLUDE_DIR)/toolchain-build.mk
BINUTILS_CONFIGURE:= \
./configure \
- --prefix=$(TOOLCHAIN_DIR)/usr \
+ --prefix=$(TOOLCHAIN_DIR) \
--build=$(GNU_HOST_NAME) \
--host=$(GNU_HOST_NAME) \
--target=$(REAL_GNU_TARGET_NAME) \
@@ -84,7 +84,7 @@ endef
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
- $(CP) $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
+ $(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
endef
define Host/Clean