aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-26 04:54:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-26 04:54:25 +0000
commit8bce44babc150874f2e9c0fab7b76e17435447e6 (patch)
tree0485514ef984a464f13689a1ee1261e30bccdbb2 /toolchain/binutils/Makefile
parentdcc294247413bfdfe0cfc50887994bcf811d95e3 (diff)
downloadmaster-187ad058-8bce44babc150874f2e9c0fab7b76e17435447e6.tar.gz
master-187ad058-8bce44babc150874f2e9c0fab7b76e17435447e6.tar.bz2
master-187ad058-8bce44babc150874f2e9c0fab7b76e17435447e6.zip
install readelf to STAGING_DIR_HOST (eglibc requires it, not all systems have it)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14196 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/binutils/Makefile')
-rw-r--r--toolchain/binutils/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index e6f60a846c..93d6392201 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -24,6 +24,7 @@ endif
PATCH_DIR:=./patches/$(PKG_VERSION)
+REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
@@ -62,6 +63,7 @@ endef
define Build/Install
$(MAKE) -C $(PKG_BUILD_DIR) install
+ $(CP) $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
endef
define Build/Clean