aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-24 10:06:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-24 10:06:55 +0000
commit1d42b9b8617e25cd3efdc73ad6018982bd8d90a8 (patch)
tree9a26aee51e61151dedca13f6f522020dd310a989 /toolchain/binutils/Makefile
parent7c11754589fca13abb7fc73e73c1e53312e92bad (diff)
downloadmaster-187ad058-1d42b9b8617e25cd3efdc73ad6018982bd8d90a8.tar.gz
master-187ad058-1d42b9b8617e25cd3efdc73ad6018982bd8d90a8.tar.bz2
master-187ad058-1d42b9b8617e25cd3efdc73ad6018982bd8d90a8.zip
binutils: remove version 2.20.1 (only used by avr32)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44960 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/binutils/Makefile')
-rw-r--r--toolchain/binutils/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 8441f740ac..9043db713f 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -10,21 +10,12 @@ PKG_NAME:=binutils
PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
BIN_VERSION:=$(PKG_VERSION)
-ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
- PKG_SOURCE_URL:=https://releases.linaro.org/14.09/components/toolchain/binutils-linaro/
- PKG_REV:=2.24.0-2014.09
- PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.xz
- PKG_MD5SUM:=8f9b2b2e049d59b1b86ce9657802a353
- BINUTILS_DIR:=$(PKG_NAME)-linaro-$(PKG_REV)
- HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
-else
- PKG_SOURCE_URL:=@GNU/binutils/
- PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-
- ifeq ($(PKG_VERSION),2.20.1)
- PKG_MD5SUM:=9cdfb9d6ec0578c166d3beae5e15c4e5
- endif
-endif
+PKG_SOURCE_URL:=https://releases.linaro.org/14.09/components/toolchain/binutils-linaro/
+PKG_REV:=2.24.0-2014.09
+PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.xz
+PKG_MD5SUM:=8f9b2b2e049d59b1b86ce9657802a353
+BINUTILS_DIR:=$(PKG_NAME)-linaro-$(PKG_REV)
+HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
HOST_BUILD_PARALLEL:=1