aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-19 02:09:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-19 02:09:59 +0000
commit08cce6702e4a883a8337b9f7f11cc39993e5cb6d (patch)
tree833af2329072275f3d93bad811b4b680e8097c91 /toolchain/binutils/Makefile
parente9cb2940e698844a7f3e3263fa5a957b3b0cc266 (diff)
downloadmaster-187ad058-08cce6702e4a883a8337b9f7f11cc39993e5cb6d.tar.gz
master-187ad058-08cce6702e4a883a8337b9f7f11cc39993e5cb6d.tar.bz2
master-187ad058-08cce6702e4a883a8337b9f7f11cc39993e5cb6d.zip
add a binutils variant based on a binutils snapshot and codesourcery g++ enhancements (compiles, but fails to link the kernel)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18060 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/binutils/Makefile')
-rw-r--r--toolchain/binutils/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index c9da2cfd78..7073507dee 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=binutils
PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
+BIN_VERSION:=$(PKG_VERSION)
PKG_SOURCE_URL:=@GNU/binutils/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -18,6 +19,13 @@ endif
ifeq ($(PKG_VERSION),2.19.1)
PKG_MD5SUM:=09a8c5821a2dfdbb20665bc0bd680791
endif
+ifeq ($(PKG_VERSION),2.19.1+cs)
+ BIN_VERSION:=20090205
+ PKG_SOURCE:=$(PKG_NAME)-$(BIN_VERSION).tar.bz2
+ PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+ PKG_MD5SUM:=040740e8c864dd1a15886753f9c0bc0b
+ HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/binutils-$(BIN_VERSION)
+endif
PATCH_DIR:=./patches/$(PKG_VERSION)