aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-09-23 02:27:38 +0000
committerNicolas Thill <nico@openwrt.org>2009-09-23 02:27:38 +0000
commitf9f42992ea38e1d88c878f4628247701c1349871 (patch)
treedb45149379d40a7638ddc3299c99ada301fe29ca /toolchain/Makefile
parente065ef25a6a6938293a72fc4be821987cdc72d56 (diff)
downloadmaster-187ad058-f9f42992ea38e1d88c878f4628247701c1349871.tar.gz
master-187ad058-f9f42992ea38e1d88c878f4628247701c1349871.tar.bz2
master-187ad058-f9f42992ea38e1d88c878f4628247701c1349871.zip
[toolchain] add external toolchain support, enhance native toolchain support (special thanks to Luigi Mantellini for his help... and patience ;)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17682 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 456b731fb8..161b139d74 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -28,13 +28,13 @@
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),,kernel-headers binutils gcc $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
# builddir dependencies
-$(curdir)/$(LIBC)/prepare:=$(curdir)/kernel-headers/install
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+ $(curdir)/$(LIBC)/prepare:=$(curdir)/kernel-headers/install
$(curdir)/gcc/prepare:=$(curdir)/binutils/install
$(curdir)/kernel-headers/install:=$(curdir)/gcc/prepare
$(curdir)/gcc/compile:=$(curdir)/$(LIBC)/prepare