aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-03-28 12:16:39 +0000
committerLuka Perkov <luka@openwrt.org>2013-03-28 12:16:39 +0000
commitd644f979e31fd5204a1818ef1512042080a52b9a (patch)
treee159e36edc5e5e1f3472bf254569f8923587a115 /toolchain/Makefile
parent349255c8d100dc48ae57d29628d7cdbd3f9b1daa (diff)
downloadmaster-187ad058-d644f979e31fd5204a1818ef1512042080a52b9a.tar.gz
master-187ad058-d644f979e31fd5204a1818ef1512042080a52b9a.tar.bz2
master-187ad058-d644f979e31fd5204a1818ef1512042080a52b9a.zip
toolchain: stop generating broken symlink in TOOLCHAIN_DIR/lib
It turns out that the symlink may exists already by the time the toolchain Makefile gets an opportunity to run. While we asked to replace the target, ln doesn't do so until after dereferencing the existing symlink. This results in an unintended symlink that refers to itself. Instead, create the link without dereferencing any symlinks by using the -n option. Signed-off-by: John Szakmeister <john@szakmeister.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36140 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index bdfb29ec17..763381a838 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -63,7 +63,7 @@ ifneq ($(ARCH),)
$(if $(QUIET),,set -x;) \
mkdir -p "$$dir"; \
cd "$$dir"; \
- ln -sf lib lib64; \
+ ln -nsf lib lib64; \
mkdir -p stamp lib usr/include usr/lib ; \
); done
@grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@