aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:08:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:08:09 +0000
commitac2f1b4f014f36e7490df7a5b31aa1fb4bd377ee (patch)
tree5882c76d27659554dfaae43b1c02487bdd358478 /toolchain/Makefile
parent39407a1e6e22fdedfe9ecb6734b0303dd5c395b6 (diff)
downloadmaster-187ad058-ac2f1b4f014f36e7490df7a5b31aa1fb4bd377ee.tar.gz
master-187ad058-ac2f1b4f014f36e7490df7a5b31aa1fb4bd377ee.tar.bz2
master-187ad058-ac2f1b4f014f36e7490df7a5b31aa1fb4bd377ee.zip
[buildroot] use ext-toolchain.sh to integrate external toolchains
Use ext-toolchain.sh to wrap external toolchain commands, abort build if certain features such as CONFIG_SOFT_FLOAT or CONFIG_IPV6 are enabled but not supported by the toolchain. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29766 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 0443924c53..3a9cd0b2f8 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -28,7 +28,7 @@
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),,kernel-headers binutils gcc/minimal gcc/initial gcc/final $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/minimal gcc/initial gcc/final $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)