aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 21:57:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 21:57:14 +0000
commita5ff10dd74547893c20294bb0c87c6ebb725c14b (patch)
tree4f3fb426cfc69b741a5efa488c370331b22a0e47 /toolchain/Makefile
parentce02916d5f22d249fc89c5f00b2d849f205b0b74 (diff)
downloadmaster-187ad058-a5ff10dd74547893c20294bb0c87c6ebb725c14b.tar.gz
master-187ad058-a5ff10dd74547893c20294bb0c87c6ebb725c14b.tar.bz2
master-187ad058-a5ff10dd74547893c20294bb0c87c6ebb725c14b.zip
no need to call compile,install on the kernel-headers dir - this gets rid of another unnecessary autorebuild check
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8247 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 9e3a781384..b11653190e 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -10,6 +10,8 @@ curdir:=toolchain
# subdirectories to descend into
$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc uClibc)
+$(curdir)/builddirs-compile:=. $(filter-out kernel-headers,$($(curdir)/builddirs))
+$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
# builddir dependencies
$(curdir)/uClibc/prepare:=$(curdir)/kernel-headers/prepare