aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commit6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e (patch)
tree30cacdb892969714d2a079f391ba6786b7c36489 /toolchain/Makefile
parent9647361f814667b536160d416666bd25ab4b82fa (diff)
downloadmaster-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.gz
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.tar.bz2
master-187ad058-6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8694 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 80bdf485df..cbc726ef01 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -39,6 +39,8 @@ $(curdir)//prepare = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk
$(curdir)//compile = $(1)/prepare
$(curdir)//install = $(1)/compile
-$(eval $(call stampfile,$(curdir),toolchain,install))
+$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+
+$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed))
$(eval $(call subdir,$(curdir)))