aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
commit13de9a716a6b7e58e3029db284574f0b4fad7eb9 (patch)
tree9805d1be913bda014319f149a2fee2ee1994722f /toolchain/Makefile
parent46b99120de90068732d8373489ff6ef2a14d73e2 (diff)
downloadmaster-187ad058-13de9a716a6b7e58e3029db284574f0b4fad7eb9.tar.gz
master-187ad058-13de9a716a6b7e58e3029db284574f0b4fad7eb9.tar.bz2
master-187ad058-13de9a716a6b7e58e3029db284574f0b4fad7eb9.zip
gcc: add llvm-gcc and llvm from trunk (does not successfully compile a target yet, but gets close)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18019 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 161b139d74..fa417879a7 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -46,6 +46,11 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
endif
endif
+ifdef CONFIG_GCC_VERSION_LLVM
+ $(curdir)/builddirs += llvm
+ $(curdir)/gcc/prepare += $(curdir)/llvm/install
+endif
+
ifneq ($(ARCH),)
$(TOOLCHAIN_DIR)/info.mk: .config
@for dir in $(TOOLCHAIN_DIR); do ( \