aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 02:16:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 02:16:37 +0000
commit08cbdbc1b095f079e37680c972b80079524290ad (patch)
tree783ba7c887edb58fc47a47c1d083b5a5e6a30ef3 /toolchain/Makefile
parent71068dead931b6d63e12715290076c02c8e68382 (diff)
downloadmaster-187ad058-08cbdbc1b095f079e37680c972b80079524290ad.tar.gz
master-187ad058-08cbdbc1b095f079e37680c972b80079524290ad.tar.bz2
master-187ad058-08cbdbc1b095f079e37680c972b80079524290ad.zip
build system cleanup. move shared include files into $(TOPDIR)/include, move lzma, mkfs.* into toolchain/
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4032 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index fac0468285..f9fb3a54d6 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -1,6 +1,6 @@
# Main makefile for the toolchain
include $(TOPDIR)/rules.mk
-TARGETS-y:=sed kernel-headers utils binutils gcc uClibc ipkg-utils libnotimpl
+TARGETS-y:=sed kernel-headers utils binutils gcc uClibc ipkg-utils libnotimpl squashfs jffs2 lzma
TARGETS-$(CONFIG_GDB) += gdb
TARGETS_DOWNLOAD:=$(patsubst %,%-source,$(TARGETS-y))
@@ -17,6 +17,7 @@ binutils-prepare: uClibc-prepare
gcc-prepare: binutils-install
uClibc-compile: gcc-prepare
gcc-compile: uClibc-install
+squashfs-compile: lzma-compile
TOOLCHAIN_STAMP_DIR:=$(STAGING_DIR)/stampfiles