aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-08 14:02:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-08 14:02:50 +0000
commitecaa0233e126c4a9a774ef50c6faa7e3cec973ae (patch)
tree5b2ff97442c8a05992f789282ccae375c1b80909 /target
parent5109b10b70d20542a3d6e1c0d529c11c028abf05 (diff)
downloadmaster-187ad058-ecaa0233e126c4a9a774ef50c6faa7e3cec973ae.tar.gz
master-187ad058-ecaa0233e126c4a9a774ef50c6faa7e3cec973ae.tar.bz2
master-187ad058-ecaa0233e126c4a9a774ef50c6faa7e3cec973ae.zip
ar71xx: allow mktplinkfw calls from the new image code to fail (because of oversized images)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45646 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 00d61ba113..d6e6285c74 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -51,15 +51,14 @@ endef
# -s strip padding from end of the image
# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
define Build/mktplinkfw
- $(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw \
-H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
-k $(word 1,$^) \
-r $@ \
-o $@.new \
-j -X 0x40000 \
-a $(call rootfs_align,$(FILESYSTEM)) \
- $(if $(findstring sysupgrade,$1),-s)
- @mv $@.new $@
+ $(if $(findstring sysupgrade,$1),-s) && mv $@.new $@ || rm -f $@
endef
# -c combined image