aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-10-27 09:42:58 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-10-27 09:42:58 +0000
commite57364c03e9180dc99ba5ae8c268e6186c3c87e6 (patch)
tree28b85abc27350586a4d3df92444ac6cdadfe5f79 /target
parente737bdee77f50eaf6a8be0fbd3dd8a50b01df83d (diff)
downloadmaster-187ad058-e57364c03e9180dc99ba5ae8c268e6186c3c87e6.tar.gz
master-187ad058-e57364c03e9180dc99ba5ae8c268e6186c3c87e6.tar.bz2
master-187ad058-e57364c03e9180dc99ba5ae8c268e6186c3c87e6.zip
[brcm47xx]: generate images for the D-Link DWL-3150 as well
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33961 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm47xx/image/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 33290ff35a..871175ed40 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -29,6 +29,11 @@ define Image/Build/wgt634u
cat $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx >> $(BIN_DIR)/openwrt-wgt634u-$(2).bin
endef
+define Image/Build/dwl3150
+ cp $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/openwrt-dwl3150-$(2).bin
+ echo "BCM-5352-2050-0000000-01" >> $(BIN_DIR)/openwrt-dwl3150-$(2).bin
+endef
+
define Image/Build/CyberTAN
$(STAGING_DIR_HOST)/bin/addpattern -4 -p $(3) -v v$(4) -i $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx -o $(BIN_DIR)/openwrt-$(2)-$(5).bin $(if $(6),-s $(6))
endef
@@ -90,6 +95,7 @@ define Image/Build/jffs2-64k
$(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Motorola,$(1),we800g,3,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Edi,$(1),ps1208mfg,$(patsubst jffs2-%,jffs2,$(1)))
+ $(call Image/Build/dwl3150,$(1),$(patsubst jffs2-%,jffs2,$(1)))
endef
define Image/Build/squashfs