aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-05 18:41:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-05 18:41:18 +0000
commite4b7bcdcd5daea12c5ee74d48132d2160b1ce899 (patch)
tree223f5c75819ae62e373c052058593332733a446a /target
parent8e411365b68a0bf7128c4668a80f41f54192c7f0 (diff)
downloadmaster-187ad058-e4b7bcdcd5daea12c5ee74d48132d2160b1ce899.tar.gz
master-187ad058-e4b7bcdcd5daea12c5ee74d48132d2160b1ce899.tar.bz2
master-187ad058-e4b7bcdcd5daea12c5ee74d48132d2160b1ce899.zip
ar71xx: image: allow to use optional parameters for MkuImageLzma/initramfs
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38658 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 811da74bcf..c934dd4adc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -91,8 +91,8 @@ define MkuImageLzma
endef
define MkuImageLzma/initramfs
- $(call PatchKernelLzma,$(1),$(2),,-initramfs)
- $(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-initramfs-$(1).bin.lzma,$(call imgname,initramfs,$(1))-uImage.bin)
+ $(call PatchKernelLzma,$(1),$(2),$(3),-initramfs)
+ $(call MkuImage,lzma,$(4),$(KDIR_TMP)/vmlinux-initramfs-$(1).bin.lzma,$(call imgname,initramfs,$(1))-uImage.bin)
endef
define MkuImageGzip