aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-04-12 09:52:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-04-12 09:52:54 +0000
commite183598d11bd54ec5b4bb272e162277137d2de3a (patch)
tree9ba08a9dcbee273492d27a618f78ae718dfd84c6 /target
parentcfef89dbe5609c22bd363e13ce754a87c95893ab (diff)
downloadmaster-187ad058-e183598d11bd54ec5b4bb272e162277137d2de3a.tar.gz
master-187ad058-e183598d11bd54ec5b4bb272e162277137d2de3a.tar.bz2
master-187ad058-e183598d11bd54ec5b4bb272e162277137d2de3a.zip
ar71xx: initial support for TP-Link Archer C7v2
The C7v2 has 16 MB flash and QCA9880-BR4A rev 2 supported by ath10k driver. The C7v1 had 8 MB flash and the unsupported QCA9880-AR1A rev 1. Signed-off-by: Adam Serbinski <adam@serbinski.com> Patchwork: http://patchwork.openwrt.org/patch/5071/ [juhosg: - remove the v2 specific profile add the ath10k driver to the existing Archer C7 profile instead. Although on v1 devices it does not change the non-working behaviour, but the ath10k driver is useful for users whom have replaced the wifi card with a supported one in their units. - update image/Makefile to build firmware image for both boards if the Archer C7 profile is selected] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40463 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk2
-rw-r--r--target/linux/ar71xx/image/Makefile4
2 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 93312740d6..aaf581b95c 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -7,7 +7,7 @@
define Profile/ARCHERC7
NAME:=TP-LINK Archer C7
- PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
endef
define Profile/ARCHERC7/Description
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 56ad1e1cbf..c9c2f56754 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1021,7 +1021,8 @@ $(eval $(call SingleProfile,TPLINK,64kraw,TLWR941NV3,tl-wr941nd-v3,TL-WR941ND,tt
$(eval $(call SingleProfile,TPLINK,64kraw,TLWR941NV4,tl-wr941nd-v4,TL-WR741ND,ttyS0,115200,0x09410004,1,4M))
$(eval $(call SingleProfile,TPLINK,64kraw,TLWR1043V1,tl-wr1043nd-v1,TL-WR1043ND,ttyS0,115200,0x10430001,1,8M))
-$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,ARCHERC7,archer-c7-v1,ARCHER-C7,ttyS0,115200,0x75000001,1,8Mlzma))
+$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,ARCHERC7V1,archer-c7-v1,ARCHER-C7,ttyS0,115200,0x75000001,1,8Mlzma))
+$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,ARCHERC7V2,archer-c7-v2,ARCHER-C7,ttyS0,115200,0xc7000002,1,16Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR10U,tl-mr10u-v1,TL-MR10U,ttyATH0,115200,0x00100101,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR11UV1,tl-mr11u-v1,TL-MR11U,ttyATH0,115200,0x00110101,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLMR11UV2,tl-mr11u-v2,TL-MR11U,ttyATH0,115200,0x00110102,1,4Mlzma))
@@ -1094,6 +1095,7 @@ $(eval $(call SingleProfile,ZyXEL,64k,NBG_460N_550N_550NH,nbg460n_550n_550nh,NBG
$(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
$(eval $(call MultiProfile,AP136,AP136_010 AP136_020))
+$(eval $(call MultiProfile,ARCHERC7, ARCHERC7V1 ARCHERC7V2))
$(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
$(eval $(call MultiProfile,OPENMESH,OM2P MR600))
$(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))