aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-03 16:15:05 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-03 16:15:05 +0000
commitd69ebca3ebf6b300ed776a9ca68ea0a54da3e654 (patch)
tree8875c062dc667ab2fd838002024cc5290c54e86c /target
parentd42a6b6d3aa74b10a4dd395b5b297991178117ae (diff)
downloadmaster-187ad058-d69ebca3ebf6b300ed776a9ca68ea0a54da3e654.tar.gz
master-187ad058-d69ebca3ebf6b300ed776a9ca68ea0a54da3e654.tar.bz2
master-187ad058-d69ebca3ebf6b300ed776a9ca68ea0a54da3e654.zip
[pxa] add Default and Gumstix PXA profiles
Gumstix builds a fake flash image for usage in qemu git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33609 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/pxa/image/Makefile14
-rw-r--r--target/linux/pxa/profiles/100-Default.mk17
-rw-r--r--target/linux/pxa/profiles/200-Gumstix.mk17
3 files changed, 47 insertions, 1 deletions
diff --git a/target/linux/pxa/image/Makefile b/target/linux/pxa/image/Makefile
index 74edb62be0..7f2b5d4123 100644
--- a/target/linux/pxa/image/Makefile
+++ b/target/linux/pxa/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,8 +15,20 @@ define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
endef
+# Build a fake flash image for usage in Qemu
+define Image/Build/Gumstix
+ dd if=/dev/zero bs=128k count=256 of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+ dd if=$(BIN_DIR)/openwrt-pxa-gumstix-u-boot.bin conv=notrunc bs=128k \
+ of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+ dd if=$(KDIR)/root.$(1) conv=notrunc bs=128k seek=2 \
+ of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+ dd if=$(KDIR)/uImage conv=notrunc bs=128k seek=248 \
+ of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
+ $(call Image/Build/$(PROFILE),$(1))
endef
define Image/Build/jffs2-64k
diff --git a/target/linux/pxa/profiles/100-Default.mk b/target/linux/pxa/profiles/100-Default.mk
new file mode 100644
index 0000000000..566a43f7b9
--- /dev/null
+++ b/target/linux/pxa/profiles/100-Default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=
+endef
+
+define Profile/Default/Description
+ Default PXA Profile
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/pxa/profiles/200-Gumstix.mk b/target/linux/pxa/profiles/200-Gumstix.mk
new file mode 100644
index 0000000000..f296414d4b
--- /dev/null
+++ b/target/linux/pxa/profiles/200-Gumstix.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Gumstix
+ NAME:=Gumstix
+ PACKAGES:=uboot-pxa-gumstix
+endef
+
+define Profile/Atheros-ath5k/Description
+ Package set compatible with the Gumstix boards
+endef
+$(eval $(call Profile,Gumstix))
+