aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-28 14:13:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-28 14:13:01 +0000
commitd4faf99fee188013eb52bc86d5582874e24362dc (patch)
treeba23cd058e4c8c0cfee83d16e55ee6256642a39b /target
parentca3c8e2a2dec20884c222f20cfb3b62d6fdb60e3 (diff)
downloadmaster-187ad058-d4faf99fee188013eb52bc86d5582874e24362dc.tar.gz
master-187ad058-d4faf99fee188013eb52bc86d5582874e24362dc.tar.bz2
master-187ad058-d4faf99fee188013eb52bc86d5582874e24362dc.zip
ramips: make tp-link firmware size errors non-fatal
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48526 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index fb064077df..6f98b00140 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -158,19 +158,19 @@ endef
define MkImageTpl/squashfs
$(eval output_name=$(IMG_PREFIX)-$(2)-$(1)-$(if $(4),$(4),sysupgrade).bin)
- $(STAGING_DIR_HOST)/bin/mktplinkfw2 -V "ver. 2.0" -B "$(2)" -j \
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw2 -V "ver. 2.0" -B "$(2)" -j \
-o $(KDIR)/$(output_name) \
-k $(KDIR)/vmlinux-$(1)$(4).bin.lzma \
- -r $(KDIR)/root.$(1)
- $(CP) $(KDIR)/$(output_name) $(BIN_DIR)/$(output_name)
+ -r $(KDIR)/root.$(1) && \
+ $(CP) $(KDIR)/$(output_name) $(BIN_DIR)/$(output_name)
endef
define MkImageTpl/initramfs
$(eval output_name=$(IMG_PREFIX)-$(2)-$(1).bin)
- $(STAGING_DIR_HOST)/bin/mktplinkfw2 -V "ver. 2.0" -B "$(2)" -c \
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw2 -V "ver. 2.0" -B "$(2)" -c \
-o $(KDIR)/$(output_name) \
- -k $(KDIR)/vmlinux-$(1).bin.lzma
- $(CP) $(KDIR)/$(output_name) $(BIN_DIR)/$(output_name)
+ -k $(KDIR)/vmlinux-$(1).bin.lzma && \
+ $(CP) $(KDIR)/$(output_name) $(BIN_DIR)/$(output_name)
endef
# $(1), lowercase board name like "mt7620a_v22sg"