aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-26 11:43:38 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-26 11:43:38 +0000
commitd1d6c6e2214103e88765ca04797896b4ab33d001 (patch)
treead225c144591c22c8797f29158039ae29883ebba /target
parentc1e89aba4d1bfa721031347dbb9144007ccc2cac (diff)
downloadmaster-187ad058-d1d6c6e2214103e88765ca04797896b4ab33d001.tar.gz
master-187ad058-d1d6c6e2214103e88765ca04797896b4ab33d001.tar.bz2
master-187ad058-d1d6c6e2214103e88765ca04797896b4ab33d001.zip
ar71xx: nbg6716: Enable procd nand sysupgrage
This enables the procd nand upgrade for ZyXEL NBG 6716. Also the ubi config is cleaned up to match the wndr4300. Signed-off-by: André Valentin <avalentin@marcant.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41346 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/image/Makefile6
-rw-r--r--target/linux/ar71xx/image/ubinize-nbg6716.ini9
3 files changed, 4 insertions, 12 deletions
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 57803ccd9d..c98737436b 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -305,6 +305,7 @@ platform_check_image() {
}
return 0
;;
+ nbg6716 | \
wndr4300 )
nand_do_platform_check $board $1
return $?;
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 877a761196..abc8b667e0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -923,7 +923,6 @@ define Image/Build/ZyXELNAND
$(eval kernelsize=$(call mtdpartsize,kernel,$(4)))
$(eval imageraw=$(KDIR_TMP)/$(2)-raw.img)
$(CP) $(KDIR)/root.$(1) $(KDIR_TMP)/ubi_root.img
- echo -ne '\xde\xad\xc0\xde' > $(KDIR_TMP)/jffs2.eof
$(call ubinize,ubinize-$(2).ini,$(KDIR_TMP),$(KDIR_TMP)/$(2)-root.ubi,128KiB,2048,-E 5)
( \
dd if=$(KDIR_TMP)/$(2)-kernel.jffs2; \
@@ -931,10 +930,7 @@ define Image/Build/ZyXELNAND
) > $(imageraw)
dd if=$(imageraw) of=$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)-factory.bin \
bs=128k conv=sync
- ( \
- dd if=$(KDIR_TMP)/$(2)-kernel.jffs2; \
- dd if=$(KDIR)/root.$(1) bs=128k conv=sync \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)-sysupgrade.bin
+ $(call Image/Build/SysupgradeNAND,$(2),squashfs,$(KDIR_TMP)/$(2)-kernel.jffs2)
endef
diff --git a/target/linux/ar71xx/image/ubinize-nbg6716.ini b/target/linux/ar71xx/image/ubinize-nbg6716.ini
index ec8d7c7fc6..814b0fbcc8 100644
--- a/target/linux/ar71xx/image/ubinize-nbg6716.ini
+++ b/target/linux/ar71xx/image/ubinize-nbg6716.ini
@@ -9,15 +9,10 @@ vol_id=0
vol_type=dynamic
# Volume name
vol_name=rootfs
-# Autoresize volume at first mount
-# vol_flags=autoresize
-vol_size=40MiB
[rootfs_data]
# Volume mode (other option is static)
mode=ubi
-# Source image
-image=jffs2.eof
# Volume ID in UBI image
vol_id=1
# Allow for dynamic resize
@@ -25,5 +20,5 @@ vol_type=dynamic
# Volume name
vol_name=rootfs_data
# Autoresize volume at first mount
-vol_size=100MiB
-#vol_flags=autoresize
+vol_size=1MiB
+vol_flags=autoresize