aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-04-21 08:19:53 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-04-21 08:19:53 +0000
commitca309341ed81407cd20d7b872f9079dffd77e196 (patch)
tree863bb851788a086062eab937f2f498c7f0285dd3 /target
parent5e70d5e345edbf6802887a674055c6c9cfa3bf16 (diff)
downloadmaster-187ad058-ca309341ed81407cd20d7b872f9079dffd77e196.tar.gz
master-187ad058-ca309341ed81407cd20d7b872f9079dffd77e196.tar.bz2
master-187ad058-ca309341ed81407cd20d7b872f9079dffd77e196.zip
bcm53xx: always use 4 MiB for TRX kernel partition to simplify upgrades
Signed-off-by: Dan Haab <dhaab@luxul.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45540 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/bcm53xx/image/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 4720aaf309..b3f2cd8127 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -31,12 +31,14 @@ define Build/mkfs/squashfs
endef
define Build/trx-nand
+ # kernel: always use 4 MiB (-28 B or TRX header) to allow upgrades even
+ # if it grows up between releases
$(STAGING_DIR_HOST)/bin/trx \
-o $@ \
-m 33554432 \
- -f $(word 1,$^) \
- -a 0x20000 -f $(KDIR)/root-block-0x20000-min-0x800.ubi \
- -a 0x20000 -A $(KDIR)/fs_mark
+ -f $(word 1,$^) -a 0x20000 -b 0x400000 \
+ -f $(KDIR)/root-block-0x20000-min-0x800.ubi -a 0x20000 \
+ -A $(KDIR)/fs_mark
endef
define Build/netgear-chk