aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-12-25 14:28:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-12-25 14:28:09 +0000
commitc85765935793bb6fdb0e980b1e150d54f9947310 (patch)
tree144af6e2444fbd42b1bf2066a6a0704d770fa50a /target
parent51866bfaa70df74222c51a89676416261fdea7df (diff)
downloadmaster-187ad058-c85765935793bb6fdb0e980b1e150d54f9947310.tar.gz
master-187ad058-c85765935793bb6fdb0e980b1e150d54f9947310.tar.bz2
master-187ad058-c85765935793bb6fdb0e980b1e150d54f9947310.zip
fix switch driver makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2778 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/package/switch/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/package/switch/Makefile b/target/linux/package/switch/Makefile
index 2f628e4b97..0d597b1f5d 100644
--- a/target/linux/package/switch/Makefile
+++ b/target/linux/package/switch/Makefile
@@ -21,6 +21,9 @@ $(PKG_BUILD_DIR)/.prepared:
cp -fpR ./src/* $(PKG_BUILD_DIR)/
touch $@
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
PATH="$(TARGET_PATH)" \
@@ -33,7 +36,7 @@ $(PKG_BUILD_DIR)/.built:
touch $@
$(IPKG_KMOD_SWITCH):
- install -m0755 $(IDIR_KMOD_SWITCH)/lib/modules/$(LINUX_VERSION)
+ install -m0755 -d $(IDIR_KMOD_SWITCH)/lib/modules/$(LINUX_VERSION)
install -m0755 -d $(IDIR_KMOD_SWITCH)/etc/modules.d
cp -fpR $(PKG_BUILD_DIR)/*.$(LINUX_KMOD_SUFFIX) \
$(IDIR_KMOD_SWITCH)/lib/modules/$(LINUX_VERSION)