aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-29 13:10:35 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-29 13:10:35 +0000
commitc06fb683fe7f7b65b6759cfe53e99f1be85dbd06 (patch)
tree4e864a44b649bc606f6561174ceaf76ae3459bc1 /target
parent01515973c13a43d9a4dd450dc1f71015f81d1d4c (diff)
downloadmaster-187ad058-c06fb683fe7f7b65b6759cfe53e99f1be85dbd06.tar.gz
master-187ad058-c06fb683fe7f7b65b6759cfe53e99f1be85dbd06.tar.bz2
master-187ad058-c06fb683fe7f7b65b6759cfe53e99f1be85dbd06.zip
[mvebu]: build firmware images for the Mamba (Linksys WRT1900AC)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41387 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/mvebu/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index fb0dc4f1f0..9de7e96086 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -44,6 +44,11 @@ endef
define Image/Build/squashfs
$(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
$(foreach dtb,$(TARGET_DTBS),$(call Image/Build/UbinizeImage,$(dtb),,squashfs,$(UBI_OPTS));)
+ ( \
+ dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \
+ dd if=$(BIN_DIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-ubinized.bin \
+ bs=2048 conv=sync; \
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-mamba-squashfs.img
endef
define Image/Build/Initramfs