aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-07-25 20:29:10 +0000
committerJohn Crispin <blogic@openwrt.org>2013-07-25 20:29:10 +0000
commitbc92ef47ece2cad013a9649a9b4d917bf070340e (patch)
tree7da799f096a3fa553674d6df03e7dfdc73c71ef7 /target
parent704179904512b1c327160fc6ba357975226d3917 (diff)
downloadmaster-187ad058-bc92ef47ece2cad013a9649a9b4d917bf070340e.tar.gz
master-187ad058-bc92ef47ece2cad013a9649a9b4d917bf070340e.tar.bz2
master-187ad058-bc92ef47ece2cad013a9649a9b4d917bf070340e.zip
lantiq: fix initramfs image generation for lzmaloader based images
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37540 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/lantiq/image/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 20840cad82..b9b410b38e 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -18,11 +18,11 @@ LOADER_MAKE := $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
define Image/BuildLoader/Template
-rm -rf $(KDIR)/lzma-loader
- $(LOADER_MAKE) LOADER=loader-$(1).$(2)\
+ $(LOADER_MAKE) LOADER=loader$(2)-$(1).bin\
LZMA_TEXT_START=0x80a00000 \
LOADADDR=0x80002000 \
- LOADER_DATA="$(KDIR)/vmlinux-$(1).lzma" BOARD="$(1)" \
- compile loader.$(2)
+ LOADER_DATA="$(KDIR)/vmlinux$(2)-$(1).lzma" BOARD="$(1)" \
+ compile loader.bin
endef
@@ -120,9 +120,15 @@ endef
define Image/BuildKernelLoader/Template
$(call PatchKernelLzma,$(1))
- $(call Image/BuildLoader/Template,$(1),bin)
+ $(call Image/BuildLoader/Template,$(1))
$(CP) $(KDIR)/loader-$(1).bin $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-loader
$(CP) $(KDIR)/vmlinux-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call PatchKernelLzma,$(1),-initramfs)
+ $(call Image/BuildLoader/Template,$(1),-initramfs)
+ $(CP) $(KDIR)/loader-initramfs-$(1).bin $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-initramfs-loader
+ $(CP) $(KDIR)/vmlinux-initramfs-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-initramfs
+endif
endef
define Image/BuildKernelEVA/Template