aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-29 00:32:44 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-29 00:32:44 +0000
commitb1c612578a673d15d082ecd9a7db41bd7f67a7d4 (patch)
tree1153d8d25d6cfdab71ea6f67a64591ca4173b3c8 /target
parent5603c178d18f2860ca03f512f9f87f95e8362819 (diff)
downloadmaster-187ad058-b1c612578a673d15d082ecd9a7db41bd7f67a7d4.tar.gz
master-187ad058-b1c612578a673d15d082ecd9a7db41bd7f67a7d4.tar.bz2
master-187ad058-b1c612578a673d15d082ecd9a7db41bd7f67a7d4.zip
replace old quote stripping with calls to qstrip macro
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21242 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/at91/image/u-boot/Makefile6
-rw-r--r--target/linux/avr32/image/u-boot/Makefile2
-rw-r--r--target/linux/x86/image/Makefile10
3 files changed, 8 insertions, 10 deletions
diff --git a/target/linux/at91/image/u-boot/Makefile b/target/linux/at91/image/u-boot/Makefile
index f53df11a90..89a2be0494 100644
--- a/target/linux/at91/image/u-boot/Makefile
+++ b/target/linux/at91/image/u-boot/Makefile
@@ -20,9 +20,9 @@ PKG_CAT:=bzcat
include $(INCLUDE_DIR)/package.mk
-UBOOT_CONFIG=$(strip $(subst ",, $(CONFIG_UBOOT_TARGET)))
-LAN_IP=$(strip $(CONFIG_UBOOT_IPADDR))
-LAN_SERVERIP=$(strip $(subst ",, $(CONFIG_UBOOT_SERVERIP)))
+UBOOT_CONFIG=$(call qstrip,$(CONFIG_UBOOT_TARGET))
+LAN_IP=$(call qstrip,$(CONFIG_UBOOT_IPADDR))
+LAN_SERVERIP=$(call qstrip,$(CONFIG_UBOOT_SERVERIP))
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
diff --git a/target/linux/avr32/image/u-boot/Makefile b/target/linux/avr32/image/u-boot/Makefile
index 2d95b87694..79bdb9f6ee 100644
--- a/target/linux/avr32/image/u-boot/Makefile
+++ b/target/linux/avr32/image/u-boot/Makefile
@@ -20,7 +20,7 @@ PKG_CAT:=bzcat
include $(INCLUDE_DIR)/package.mk
-UBOOT_CONFIG=$(strip $(subst ",, $(CONFIG_AVR32_UBOOT_TARGET)))
+UBOOT_CONFIG=$(call qstrip,$(CONFIG_AVR32_UBOOT_TARGET))
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 2a6a2e336d..a4399a2b4b 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -10,15 +10,13 @@ include $(INCLUDE_DIR)/image.mk
export PATH=$(TARGET_PATH):/sbin
ifneq ($(CONFIG_TARGET_x86_olpc),y)
-BOOTOPTS=$(strip $(subst ",, $(CONFIG_X86_GRUB_BOOTOPTS)))
-ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
-#"))")) # fix vim's broken syntax highlighting
+BOOTOPTS=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
+ROOTPART=$(call qstrip,$(CONFIG_X86_GRUB_ROOTPART))
endif
ifeq ($(CONFIG_TARGET_x86_olpc),y)
-ROOTPART=$(strip $(subst ",, $(CONFIG_OLPC_BOOTSCRIPT_ROOTPART)))
+ROOTPART=$(call qstrip,$(CONFIG_OLPC_BOOTSCRIPT_ROOTPART))
endif
-#"))")) # fix vim's broken syntax highlighting
GRUB_TERMINALS =
GRUB_SERIAL_CONFIG =
@@ -31,7 +29,7 @@ GRUB_TERMINALS += console
endif
ifneq ($(CONFIG_X86_GRUB_SERIAL),)
-GRUB_CONSOLE_CMDLINE += console=$(strip $(subst ",, $(CONFIG_X86_GRUB_SERIAL))),$(CONFIG_X86_GRUB_BAUDRATE)n8
+GRUB_CONSOLE_CMDLINE += console=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL)),$(CONFIG_X86_GRUB_BAUDRATE)n8
GRUB_SERIAL_CONFIG = serial --unit=0 --speed=$(CONFIG_X86_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
GRUB_TERMINALS += serial
endif