aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-08 16:10:41 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-08 16:10:41 +0000
commit98f63520b4c523d45ecd124534e4e9ee56e1259e (patch)
treec972d9e2c109ddb4e72bfe4b3a761f2c5248b488 /target
parent5977a6451296f0de45a4d8ab7cd408c6a2a803dc (diff)
downloadmaster-187ad058-98f63520b4c523d45ecd124534e4e9ee56e1259e.tar.gz
master-187ad058-98f63520b4c523d45ecd124534e4e9ee56e1259e.tar.bz2
master-187ad058-98f63520b4c523d45ecd124534e4e9ee56e1259e.zip
brcm63xx: add DT support for DSL-2640B
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43571 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/dts/dsl-2640b-b.dts30
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile4
-rw-r--r--target/linux/brcm63xx/patches-3.14/500-board-D4PW.patch8
-rw-r--r--target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.18/500-board-D4PW.patch8
-rw-r--r--target/linux/brcm63xx/patches-3.18/514-board_ct536_ct5621.patch2
-rw-r--r--target/linux/brcm63xx/profiles/d-link.mk9
7 files changed, 59 insertions, 4 deletions
diff --git a/target/linux/brcm63xx/dts/dsl-2640b-b.dts b/target/linux/brcm63xx/dts/dsl-2640b-b.dts
new file mode 100644
index 0000000000..efc0dc577f
--- /dev/null
+++ b/target/linux/brcm63xx/dts/dsl-2640b-b.dts
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+ model = "D-Link DSL-2640B rev B2";
+ compatible = "d-link,dsl-2640b-b", "brcm,bcm6348";
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x010000>;
+ read-only;
+ };
+
+ linux@10000 {
+ label = "linux";
+ reg = <0x010000 0x3e0000>;
+ };
+
+ nvram@3f0000 {
+ label = "nvram";
+ reg = <0x3f0000 0x010000>;
+ };
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 30fb36335f..48492fabf6 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -206,8 +206,6 @@ define Image/Build
$(call Image/Build/CFE,$(1),96348GW-10,6348,DG834GT_DG834PN)
# Belkin f5d7633
$(call Image/Build/CFE,$(1),96348GW-10,6348,F5D7633)
- # D-Link DSL-2640B, rev B2
- $(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B-B2)
# TP-Link 8900GB
$(call Image/Build/CFE,$(1),96348GW-11,6348,TD8900GB,$(shell printf 'PRID\x89\x10\x00\x02'))
@@ -283,6 +281,8 @@ $(eval $(call ImageDTB,CFEDTB,VR3025u,vr-3025u,96368M-1541N,6368,VR-3025u,--pad
$(eval $(call ImageDTB,CFEDTB,VR3025un,vr-3025un,96368M-1341N,6368,VR-3025un,--pad 4))
# Comtrend WAP-5813n
$(eval $(call ImageDTB,CFEDTB,WAP5813n,wap-5813n,96369R-1231N,6368,WAP-5813n,--pad 4))
+# D-Link DSL-2640B, rev B2
+$(eval $(call ImageDTB,CFEDTB,DSL2640B_B,dsl-2640b-b,D-4P-W,6348,DSL2640B-B2))
# D-Link DSL-2650U
$(eval $(call ImageDTB,CFEDTB,DSL2650U,dsl-2650u,96358VW2,6358,DSL2650U))
# D-Link DSL-2740B/DSL-2741B, rev C2
diff --git a/target/linux/brcm63xx/patches-3.14/500-board-D4PW.patch b/target/linux/brcm63xx/patches-3.14/500-board-D4PW.patch
index b54a3e5443..25b558ac5c 100644
--- a/target/linux/brcm63xx/patches-3.14/500-board-D4PW.patch
+++ b/target/linux/brcm63xx/patches-3.14/500-board-D4PW.patch
@@ -65,3 +65,11 @@
#endif
#ifdef CONFIG_BCM63XX_CPU_6358
+@@ -755,6 +806,7 @@ static struct of_device_id const bcm963x
+ { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
+ { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+ { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
++ { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
+ { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
+ { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+ { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
diff --git a/target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch b/target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch
index 4c44094d43..f6a655b135 100644
--- a/target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch
+++ b/target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch
@@ -73,6 +73,6 @@
{ .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
+ { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
+ { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
+ { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
{ .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
{ .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
- { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
diff --git a/target/linux/brcm63xx/patches-3.18/500-board-D4PW.patch b/target/linux/brcm63xx/patches-3.18/500-board-D4PW.patch
index b54a3e5443..25b558ac5c 100644
--- a/target/linux/brcm63xx/patches-3.18/500-board-D4PW.patch
+++ b/target/linux/brcm63xx/patches-3.18/500-board-D4PW.patch
@@ -65,3 +65,11 @@
#endif
#ifdef CONFIG_BCM63XX_CPU_6358
+@@ -755,6 +806,7 @@ static struct of_device_id const bcm963x
+ { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
+ { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+ { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
++ { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
+ { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
+ { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+ { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
diff --git a/target/linux/brcm63xx/patches-3.18/514-board_ct536_ct5621.patch b/target/linux/brcm63xx/patches-3.18/514-board_ct536_ct5621.patch
index 4c44094d43..f6a655b135 100644
--- a/target/linux/brcm63xx/patches-3.18/514-board_ct536_ct5621.patch
+++ b/target/linux/brcm63xx/patches-3.18/514-board_ct536_ct5621.patch
@@ -73,6 +73,6 @@
{ .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
+ { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
+ { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
+ { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
{ .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
{ .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
- { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
diff --git a/target/linux/brcm63xx/profiles/d-link.mk b/target/linux/brcm63xx/profiles/d-link.mk
index 4bfefb9ee4..71f6421535 100644
--- a/target/linux/brcm63xx/profiles/d-link.mk
+++ b/target/linux/brcm63xx/profiles/d-link.mk
@@ -5,6 +5,15 @@
# See /LICENSE for more information.
#
+define Profile/DSL2640B_B
+ NAME:=D-Link DSL-2640B rev B2
+ PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/DSL2640B_B/Description
+ Package set optimized for DSL-2640B rev B2.
+endef
+$(eval $(call Profile,DSL2640B_B))
+
define Profile/DSL2650U
NAME:=D-Link DSL-2650U
PACKAGES:=kmod-b43 wpad-mini\