aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-26 15:52:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-26 15:52:12 +0000
commit7dd7852ba2d9ab29c610461ed61c2428c34e8759 (patch)
treecc27fd3cfca0cccad6db8cbd6ffe811e5adea94a /target
parent1a001483d28c98e8a392a9dc21c95aaf947b4d07 (diff)
downloadmaster-187ad058-7dd7852ba2d9ab29c610461ed61c2428c34e8759.tar.gz
master-187ad058-7dd7852ba2d9ab29c610461ed61c2428c34e8759.tar.bz2
master-187ad058-7dd7852ba2d9ab29c610461ed61c2428c34e8759.zip
clean up board-dependent files, add pppoatm support, add proper config examples
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1754 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/package/openwrt/Makefile6
-rw-r--r--target/linux/package/openwrt/files/ar7/etc/config/network31
-rw-r--r--target/linux/package/openwrt/files/ar7/etc/network.overrides (renamed from target/linux/package/openwrt/files/network.overrides.ar7)0
-rw-r--r--target/linux/package/openwrt/files/brcm/etc/config/network18
-rwxr-xr-xtarget/linux/package/openwrt/files/brcm/etc/init.d/S05nvram (renamed from target/linux/package/openwrt/files/S05nvram.brcm)0
-rw-r--r--target/linux/package/openwrt/files/brcm/etc/network.overrides (renamed from target/linux/package/openwrt/files/network.overrides.brcm)0
-rw-r--r--target/linux/package/openwrt/files/soekris/etc/config/network10
-rw-r--r--target/linux/package/openwrt/files/soekris/etc/network.overrides (renamed from target/linux/package/openwrt/files/network.overrides.soekris)0
8 files changed, 62 insertions, 3 deletions
diff --git a/target/linux/package/openwrt/Makefile b/target/linux/package/openwrt/Makefile
index 6fb20d6229..6fa350a9dd 100644
--- a/target/linux/package/openwrt/Makefile
+++ b/target/linux/package/openwrt/Makefile
@@ -36,9 +36,9 @@ $(IDIR_OPENWRT):
$(SED) s,base-files-arch,base-files-$(BOARD),g $(IDIR_OPENWRT)/CONTROL/control
$(IPKG_OPENWRT): $(IDIR_OPENWRT)
- mkdir -p $(IDIR_OPENWRT)/etc/init.d
- [ -f files/network.overrides.$(BOARD) ] && cp files/network.overrides.$(BOARD) $(IDIR_OPENWRT)/etc/network.overrides
- [ -f files/S05nvram.$(BOARD) ] && install -m0755 files/S05nvram.$(BOARD) $(IDIR_OPENWRT)/etc/init.d/S05nvram
+ [ -d files/$(BOARD) ] && cp -a files/$(BOARD)/* $(IDIR_OPENWRT)/
+ find $(IDIR_OPENWRT) -name CVS | xargs rm -rf
+ find $(IDIR_OPENWRT) -name .svn | xargs rm -rf
$(RSTRIP) $(IDIR_OPENWRT)
$(IPKG_BUILD) $(IDIR_OPENWRT) $(PACKAGE_DIR)
diff --git a/target/linux/package/openwrt/files/ar7/etc/config/network b/target/linux/package/openwrt/files/ar7/etc/config/network
new file mode 100644
index 0000000000..785ad05ee6
--- /dev/null
+++ b/target/linux/package/openwrt/files/ar7/etc/config/network
@@ -0,0 +1,31 @@
+# Network configuration file
+# Uncomment the following statements to change the network configuration
+
+## LAN configuration
+# lan_ifame="br0"
+# lan_proto="static"
+# lan_ipaddr="192.168.1.1"
+# lan_netmask="255.255.255.0"
+# lan_gateway=""
+# lan_dns=""
+
+## WAN configuration (PPPoE)
+# wan_type=pppoe
+# wan_ifname=ppp0
+# pppoe_atm=1
+# pppoe_ifname=nas0
+# atm_vpi=8
+# atm_vci=35
+# ppp_username=my_username
+# ppp_passwd=my_passwd
+# ppp_mtu=1492
+
+## WAN configuration (PPPoA)
+# wan_type=pppoa
+# wan_ifname=ppp0
+# atm_vpi=8
+# atm_vci=35
+# ppp_username=my_username
+# ppp_passwd=my_passwd
+# ppp_mtu=1492
+
diff --git a/target/linux/package/openwrt/files/network.overrides.ar7 b/target/linux/package/openwrt/files/ar7/etc/network.overrides
index 9c0e814059..9c0e814059 100644
--- a/target/linux/package/openwrt/files/network.overrides.ar7
+++ b/target/linux/package/openwrt/files/ar7/etc/network.overrides
diff --git a/target/linux/package/openwrt/files/brcm/etc/config/network b/target/linux/package/openwrt/files/brcm/etc/config/network
new file mode 100644
index 0000000000..6f09a502a8
--- /dev/null
+++ b/target/linux/package/openwrt/files/brcm/etc/config/network
@@ -0,0 +1,18 @@
+# Network configuration file
+# Uncomment the following statements to override the default or nvram config
+
+## LAN configuration
+# lan_ifame="br0"
+# lan_proto="static"
+# lan_ipaddr="192.168.1.1"
+# lan_netmask="255.255.255.0"
+# lan_gateway=""
+# lan_dns=""
+
+## WAN configuration (PPPoE)
+# wan_type=pppoe
+# wan_ifname=ppp0
+# pppoe_ifname=vlan1
+# ppp_username=my_username
+# ppp_passwd=my_passwd
+# ppp_mtu=1492
diff --git a/target/linux/package/openwrt/files/S05nvram.brcm b/target/linux/package/openwrt/files/brcm/etc/init.d/S05nvram
index 0d1300b964..0d1300b964 100755
--- a/target/linux/package/openwrt/files/S05nvram.brcm
+++ b/target/linux/package/openwrt/files/brcm/etc/init.d/S05nvram
diff --git a/target/linux/package/openwrt/files/network.overrides.brcm b/target/linux/package/openwrt/files/brcm/etc/network.overrides
index 66f1abd248..66f1abd248 100644
--- a/target/linux/package/openwrt/files/network.overrides.brcm
+++ b/target/linux/package/openwrt/files/brcm/etc/network.overrides
diff --git a/target/linux/package/openwrt/files/soekris/etc/config/network b/target/linux/package/openwrt/files/soekris/etc/config/network
new file mode 100644
index 0000000000..8383edbb50
--- /dev/null
+++ b/target/linux/package/openwrt/files/soekris/etc/config/network
@@ -0,0 +1,10 @@
+# Network configuration file
+# Uncomment the following statements to override the default or nvram config
+
+## LAN configuration
+# lan_ifame="br0"
+# lan_proto="static"
+# lan_ipaddr="192.168.1.1"
+# lan_netmask="255.255.255.0"
+# lan_gateway=""
+# lan_dns=""
diff --git a/target/linux/package/openwrt/files/network.overrides.soekris b/target/linux/package/openwrt/files/soekris/etc/network.overrides
index e857d5b5f1..e857d5b5f1 100644
--- a/target/linux/package/openwrt/files/network.overrides.soekris
+++ b/target/linux/package/openwrt/files/soekris/etc/network.overrides