aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-14 11:39:20 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-14 11:39:20 +0000
commit697f52699573a8aea0bd5db6f892ee10282f3960 (patch)
tree7699692adbd729bdd9132db971656b5379560bba /target
parentabdd10c1d5b5f09368925d56f305c0218cc49f43 (diff)
downloadmaster-187ad058-697f52699573a8aea0bd5db6f892ee10282f3960.tar.gz
master-187ad058-697f52699573a8aea0bd5db6f892ee10282f3960.tar.bz2
master-187ad058-697f52699573a8aea0bd5db6f892ee10282f3960.zip
mvebu: Switch to the generic mkuimage macro
The mvebu image makefile define something almost identical to the generic implementation found in include/image.mk. Switch to this implementation. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43969 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/mvebu/image/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index f265dc43d2..6e00346fe2 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -24,15 +24,12 @@ KDIR_TMP:=$(KDIR)/tmp
UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
-define Image/Build/MkuImage
- mkimage -A arm -O linux -T kernel -a $(LOADADDR) -C none -e $(LOADADDR) \
- -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(1) $(2);
-endef
-
define Image/Build/DTB
cp $(KDIR)/zImage$(2) $(KDIR)/zImage$(2)-$(1);
cat $(DTS_DIR)/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
- $(call Image/Build/MkuImage,$(KDIR)/zImage$(2)-$(1),$(KDIR)/uImage$(2)-$(1))
+ $(call Image/BuildKernel/MkuImage, \
+ none, $(LOADADDR), $(LOADADDR), \
+ $(KDIR)/zImage$(2)-$(1), $(KDIR)/uImage$(2)-$(1))
cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
endef