aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-25 22:18:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-25 22:18:17 +0000
commit614123e8019c30ca542ea26d7c9088745814435c (patch)
tree18205afd6e3a8b1b29bd8699a879ed337ec8152e /target
parent25fdbd4c4b1ca76029b33bf03c6f0295868f382a (diff)
downloadmaster-187ad058-614123e8019c30ca542ea26d7c9088745814435c.tar.gz
master-187ad058-614123e8019c30ca542ea26d7c9088745814435c.tar.bz2
master-187ad058-614123e8019c30ca542ea26d7c9088745814435c.zip
kernel: remove wrong chunks from the 2.6.37 and 2.6.38 version of the mips oprofile fix
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26297 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch12
-rw-r--r--target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch12
2 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch b/target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch
index 2841ed883e..f83c96bb81 100644
--- a/target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch
+++ b/target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch
@@ -1,15 +1,3 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
- endif
- endif
-
-+ifndef CONFIG_PROFILING
-+ cflags-y := -ffunction-sections
-+endif
- ifdef CONFIG_FUNCTION_GRAPH_TRACER
- ifndef KBUILD_MCOUNT_RA_ADDRESS
- ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
--- a/arch/mips/oprofile/op_model_mipsxx.c
+++ b/arch/mips/oprofile/op_model_mipsxx.c
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
diff --git a/target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch b/target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch
index 2841ed883e..f83c96bb81 100644
--- a/target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch
+++ b/target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch
@@ -1,15 +1,3 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
- endif
- endif
-
-+ifndef CONFIG_PROFILING
-+ cflags-y := -ffunction-sections
-+endif
- ifdef CONFIG_FUNCTION_GRAPH_TRACER
- ifndef KBUILD_MCOUNT_RA_ADDRESS
- ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
--- a/arch/mips/oprofile/op_model_mipsxx.c
+++ b/arch/mips/oprofile/op_model_mipsxx.c
@@ -298,6 +298,11 @@ static void reset_counters(void *arg)