aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-26 16:15:26 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-26 16:15:26 +0000
commit5f5eef6ea26b1d9942cc578f592c6a31b2c0c93a (patch)
treea396ca606646a5bcb02b504de94b7b15c494a03f /target
parent0ab259ab73c08619b9ce3dd41803483aca5a0d81 (diff)
downloadmaster-187ad058-5f5eef6ea26b1d9942cc578f592c6a31b2c0c93a.tar.gz
master-187ad058-5f5eef6ea26b1d9942cc578f592c6a31b2c0c93a.tar.bz2
master-187ad058-5f5eef6ea26b1d9942cc578f592c6a31b2c0c93a.zip
[ppc40x] allow creating of ext2 filesystems
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17017 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ppc40x/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index d9586dd153..3afeeca4ad 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -22,6 +22,10 @@ define Image/Build
$(call Image/Build/$(1),$(1))
endef
+define Image/Build/ext2
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-ext2.img
+endef
+
define Image/Build/jffs2-128k
( \
dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \