aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-30 20:20:08 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-30 20:20:08 +0000
commit5c7193d17b8444ca2c42ddea87b3707e035376f2 (patch)
tree732391b371efd6179179f408afe06b5064203e6f /target
parent0d349dc5fe18ae68ee4a5e59373eb788b3f482e1 (diff)
downloadmaster-187ad058-5c7193d17b8444ca2c42ddea87b3707e035376f2.tar.gz
master-187ad058-5c7193d17b8444ca2c42ddea87b3707e035376f2.tar.bz2
master-187ad058-5c7193d17b8444ca2c42ddea87b3707e035376f2.zip
ramips: move relocating loader to common location
Allow other targets to use it, too. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45162 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/generic/image/relocate/Makefile (renamed from target/linux/ramips/image/relocate/Makefile)0
-rw-r--r--target/linux/generic/image/relocate/cacheops.h (renamed from target/linux/ramips/image/relocate/cacheops.h)0
-rw-r--r--target/linux/generic/image/relocate/cp0regdef.h (renamed from target/linux/ramips/image/relocate/cp0regdef.h)0
-rw-r--r--target/linux/generic/image/relocate/head.S (renamed from target/linux/ramips/image/relocate/head.S)0
-rw-r--r--target/linux/generic/image/relocate/loader.lds (renamed from target/linux/ramips/image/relocate/loader.lds)0
-rw-r--r--target/linux/ramips/image/Makefile2
6 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/relocate/Makefile b/target/linux/generic/image/relocate/Makefile
index 500423b63b..500423b63b 100644
--- a/target/linux/ramips/image/relocate/Makefile
+++ b/target/linux/generic/image/relocate/Makefile
diff --git a/target/linux/ramips/image/relocate/cacheops.h b/target/linux/generic/image/relocate/cacheops.h
index 70bcad7694..70bcad7694 100644
--- a/target/linux/ramips/image/relocate/cacheops.h
+++ b/target/linux/generic/image/relocate/cacheops.h
diff --git a/target/linux/ramips/image/relocate/cp0regdef.h b/target/linux/generic/image/relocate/cp0regdef.h
index c1188ad8c8..c1188ad8c8 100644
--- a/target/linux/ramips/image/relocate/cp0regdef.h
+++ b/target/linux/generic/image/relocate/cp0regdef.h
diff --git a/target/linux/ramips/image/relocate/head.S b/target/linux/generic/image/relocate/head.S
index 3e5b374ba0..3e5b374ba0 100644
--- a/target/linux/ramips/image/relocate/head.S
+++ b/target/linux/generic/image/relocate/head.S
diff --git a/target/linux/ramips/image/relocate/loader.lds b/target/linux/generic/image/relocate/loader.lds
index 98ca209303..98ca209303 100644
--- a/target/linux/ramips/image/relocate/loader.lds
+++ b/target/linux/generic/image/relocate/loader.lds
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 45ae3a585a..14f6f1ef7e 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -981,7 +981,7 @@ endif
ifeq ($(SUBTARGET),mt7621)
define Build/Compile
rm -rf $(KDIR)/relocate
- $(CP) ./relocate $(KDIR)
+ $(CP) ../../generic/image/relocate $(KDIR)
$(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
endef
endif